Login issues caused by Certificate Error in Browser
Incident Report for SysAid
Postmortem

On 2 May 2022, between 19:50-22:00 UTC, some customers using the Google Chrome browser experienced certificate errors that prevented users from logging in to their system. 

It appears that this issue affected many different services across the globe. It originated with changes to Google’s infrastructure and process of evaluating valid certificates. To quickly mitigate the issue we implemented new certificates from a different provider and have verified that our customers are no longer experiencing the errors.

We resolved the error within three hours of notification. SysAid will continue to investigate further to mitigate future incidents, and remain committed to providing our customers with a stable and secure platform

Posted May 04, 2022 - 12:58 UTC

Resolved
This incident has been resolved.
Posted May 02, 2022 - 22:05 UTC
Update
We are continuing to monitor for any further issues.
Posted May 02, 2022 - 21:55 UTC
Update
We are continuing to monitor for any further issues.
Posted May 02, 2022 - 21:33 UTC
Update
We are continuing to monitor for any further issues.
Posted May 02, 2022 - 21:31 UTC
Update
We are continuing to monitor for any further issues.
Posted May 02, 2022 - 21:25 UTC
Update
Monitoring - A fix has been implemented and we are monitoring the results.
Posted May 02, 2022 - 21:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2022 - 21:18 UTC
Update
We are continuing to investigate this issue.
Posted May 02, 2022 - 19:59 UTC
Update
We are continuing to investigate this issue.
Posted May 02, 2022 - 19:58 UTC
Update
We are continuing to investigate this issue.
Posted May 02, 2022 - 19:51 UTC
Investigating
We are currently investigating this issue.
Posted May 02, 2022 - 19:51 UTC
This incident affected: North America (INST03US, INST04US, INST05US, INST06US, INST07US, INST08US, INST09US, INST10US, INST11US, INST80CA).