SysAid - Service disruptions / Performance degradation – Incident details

Service disruptions / Performance degradation

Resolved
Major outage
Started about 1 month agoLasted about 2 hours

Affected

North America

Major outage from 5:00 PM to 6:34 PM

INST04US

Major outage from 5:00 PM to 6:34 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Our team has identified a service disruption / performance degradation, we are currently investigating and will update accordingly.

    You can visit the following page for ongoing updates: SysAid’s Cloud Status Page

    Feel free to contact our Customer Care Team directly if you have any questions.

    Sincerely,

    The SysAid Team